Khoros Care - Login Issues

Incident Report for Khoros

Resolved

The issue has been resolved.
Posted Feb 19, 2026 - 22:23 CST

Monitoring

We have resolved the issue preventing some users from passing the welcome screen when logging in to Khoros Care.
Please ensure that browser Cache is cleared in order for the fix to apply correctly.
We are actively monitoring the situation.
Posted Feb 18, 2026 - 18:24 CST

Investigating

We are aware of an issue preventing some users from passing the welcome screen when logging into Khoros Care.
Our Infrastructure team are actively investigating this issue.
Posted Feb 18, 2026 - 15:45 CST
This incident affected: Khoros Care (APAC Hosted Care, EU Hosted Care, US Hosted Care).