[Care] Performance degradation for a subset of customers in AMER region

Incident Report for Khoros

Resolved

This incident has been resolved.
Posted May 15, 2025 - 13:03 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 05, 2025 - 10:29 CDT

Investigating

We are experiencing performance degradation in Care which affects customers from AMER region. As a result, agents will notice latency/slowness in the platform.
We are actively investigating the issue, and we will keep you updated on the progress.
Posted May 05, 2025 - 09:20 CDT
This incident affected: Khoros Care (US Hosted Care).