Khoros Marketing - Conversations: Facebook API issue causing Publishing failures for some Video Posts
Incident Report for Khoros
Resolved
Khoros implemented an alternative large video upload mechanism as recommended by Facebook. This mechanism was implemented morning CT Dec 12, since that time we have seen a 99-100% video publishing success rate, with no "reduce data error" types - which has been the source root error indicated by Facebook to Khoros.

Khoros will continue to track progress ahead. In interim, we will now remove the Degraded Performance status. Facebook is still working towards a more complete and permanent fix regarding large video files on their side.

Thank you for your patience as we brought this matter to resolve.
Posted Dec 13, 2019 - 10:14 CST
Update
Friday, Nov 25 - Khoros received communication from Facebook that they are still evaluating the scale of the problem and are working to resolve over the next several weeks. In interim, they recommended an alternative large video upload mechanism for Khoros to utilize to potentially increase success rate of video publishing.

Khoros infrastructure team initiated this new mechanism week of December 2, anticipating this work to conclude by week-end of December 13. Please note that while this new mechanism may fix the issue for some videos, we anticipate complete recovery as Facebook works towards a more complete and permanent fix.
Posted Dec 05, 2019 - 13:51 CST
Update
To track Facebook's updates on this issue please follow here: https://developers.facebook.com/support/bugs/422744301607613/
Posted Nov 22, 2019 - 17:36 CST
Update
Since October 24, Khoros and Facebook have been experiencing a bug for video publishing with a "Please reduce data" exception. On November 5, Khoros implemented two improvements to our end customers' retry experience to improve the chances of video publishing success. Additionally, Khoros revised the in-product error to indicate this was a known issue.

Since this change we have seen the number of publishing failures go down; however, they do persist. Facebook is still in progress of addressing this bug on their side. Khoros has continued to inform them of customer publishing issues.

In interim, if you continue facing issues with Facebook video publishing, video size and length reductions may increase chances of success.
Posted Nov 22, 2019 - 15:38 CST
Update
Our Engineering team is still investigating this issue.
Posted Oct 30, 2019 - 20:49 CDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 24, 2019 - 17:56 CDT
Identified
We have identified an issue with Social Marketing products that a current issue with FB's API is causing certain posts to fail. if you run into this please attempt to republish the content and if it continues to fail. Feel free to reach out to support and we will work to verify
Posted Oct 24, 2019 - 17:51 CDT