We have confirmed that the fix that was implemented has resolved this issue.
Posted Feb 19, 2026 - 15:40 CST
Monitoring
A fix has been implemented and we are monitoring results.
Posted Feb 18, 2026 - 12:56 CST
Update
The fix is currently being incrementally applied. As a result, performance is gradually improving. We will provide another update once the rollout is fully completed and performance has been fully restored.
Posted Feb 18, 2026 - 10:25 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 18, 2026 - 09:07 CST
Investigating
We are experiencing an ongoing issue affecting ingestion and queue processing. As a result, cases and messages may appear in the Available queue or in agent queues much later than expected (from several minutes up to an hour or more), and assignment to agents can be delayed.
Posted Feb 18, 2026 - 01:38 CST
This incident affected: Khoros Care (US Hosted Care).