[Care, Marketing - X Platform] Disruption in X API

Incident Report for Khoros

Resolved

The issue has been resolved, which was caused by unexpected changes from X.
Posted Jun 09, 2025 - 22:20 CDT

Monitoring

We've implemented a workaround for the incident and can confirm that the affected services have been restored and are currently functioning as expected. We will continue to monitor the situation closely and share any further updates as needed.
Posted Jun 03, 2025 - 15:46 CDT

Update

We are continuing to collaborate with X to investigate this remaining issue with the Media Upload v2 endpoints and will keep you updated on further progress.

The status is also updated on X's incident page for ongoing issue with "POST /2/media/upload - 404 errors"
https://docs.x.com/incidents
Posted Jun 02, 2025 - 09:11 CDT

Update

We can confirm that X has resolved the issues outlined on their status page. However, we are still seeing errors on the Media Upload v2 endpoints. We are actively collaborating with X to investigate this remaining issue and will keep you updated as we receive further information.
Posted May 30, 2025 - 22:38 CDT

Identified

We identified the issue with the X API, and we are coordinating with them.
We will keep you updated on further updates.
Posted May 30, 2025 - 19:43 CDT

Monitoring

We are aware of ongoing issues with the X API resulting in various failures.

As a result, you may notice intermittent performance issues concerning engaging/ingesting X content into the Khoros Care & Marketing platforms.

We are monitoring the issues with the X API and will keep you posted on further updates.
Posted May 30, 2025 - 15:05 CDT
This incident affected: Khoros Marketing (Organic Publishing, Social Inbox, Agent Inbox) and Khoros Care (X API (Formerly Twitter API)).