Khoros Care (EU region) - Degraded Performance

Incident Report for Khoros

Resolved

We have observed no further performance issues. This issue is now resolved.
Posted Jul 09, 2026 - 21:43 CDT

Monitoring

We have applied infrastructure fixes overnight during a low-traffic window. Since this morning, performance metrics for EU Care have returned to normal and remained stable through peak hours. We are actively monitoring throughout the day to confirm stability. Additional preventive maintenance is scheduled for the coming weekend during off-peak hours.
Posted Jul 09, 2026 - 07:11 CDT

Identified

We have identified the cause of the current issue and are applying immediate fixes to reduce the impact. Additional permanent fixes will be implemented over the weekend to fully resolve the problem. We will continue to share updates as they become available.
Posted Jul 08, 2026 - 14:46 CDT

Investigating

We are investigating intermittent delays affecting some Khoros Care customers, where new contacts may take longer than usual to appear in queues, queue counts may display inaccurately, and agent actions such as assigning cases or posting responses may be slow. Message ingestion is not affected and no data is lost — these issues impact visibility and agent workflow only. Our team is actively working to resolve this and will share updates as they become available.
Posted Jul 08, 2026 - 12:45 CDT
This incident affected: Khoros Care (EU Hosted Care).