[JX] JCA portal is not displaying properly
Incident Report for Khoros
Resolved
The JCA page is now displaying normally.
Posted Jun 06, 2019 - 10:25 CDT
Investigating
The JCA page is currently not displaying any of the normal information or login capabilities.

There have been reports of limited success when switching browsers or utilizing incognito mode. Sites remain up as do our back-end admin tools.
Posted May 31, 2019 - 14:14 CDT